Trouble with Detect Invisible

Discuss the new 3D Ogre engine based client here.
amenius
Posts: 2
Joined: Sun Nov 05, 2017 9:48 pm

Trouble with Detect Invisible

Postby amenius » Sun Nov 05, 2017 9:59 pm

Hi all,

first of all, I would like to send a huge thanks to all of you who have improved M59 since it became open source. I really like those changes!

However, with the Ogre Client, I'm having Trouble every time I cast Detect Invisible (as well as everytime the spell wears off): The Client freezes for about a second or two. Not really much but we all know how relevant a second can be at M59. :-)

Is it just my Lenovo ThinkPad T440 or can I Change anything to fix this?

Thanks and best,
Amenius
Delerium
Site Admin
Posts: 95
Joined: Mon Mar 21, 2016 8:33 am

Re: Trouble with Detect Invisible

Postby Delerium » Mon Nov 06, 2017 8:31 am

When you cast DI it refreshes all the room contents which on an older computer is probably giving you the same delay you'd experience entering a room for the first time. It might not be as easy to notice on room change since delay is more expected then.

Do you have the same issue when casting Detect Good or Detect Evil, or having them cast on you? If you can, please test one or both of these and let me know the results. I think there's a way to lessen or remove the delay and the extra data would be helpful.
amenius
Posts: 2
Joined: Sun Nov 05, 2017 9:48 pm

Re: Trouble with Detect Invisible

Postby amenius » Mon Nov 06, 2017 10:23 pm

Hi Delerium,

thanks for looking into this! I indeed have a significant delay everytime I enter a new room. Depending on the room I would say 1-5 seconds.

Regarding detect good, i have the same issue (never used the spell before). In Tos, the freeze lasts about 2 seconds.

Hope this helps!
Delerium
Site Admin
Posts: 95
Joined: Mon Mar 21, 2016 8:33 am

Re: Trouble with Detect Invisible

Postby Delerium » Sun Nov 26, 2017 3:28 pm

An update on this issue, I've been testing this out and I found a way to lower the delay from ~1.2ms to anywhere from 0ms - 0.001ms depending on how many invis objects are on screen. It should remove the delay completely for you when we patch (no solid date, but fairly soon).

Who is online

Users browsing this forum: No registered users and 1 guest